nissan forums   nissan forums

Go Back   Nissan Forum > Nissan Forums (Nissan Cars) > Nissan Versa Forum


Nissan Forum: Engine and transmission still rocks
Thread Tools Display Modes
Old 02-04-2018, 06:55 PM
jamesm jamesm is offline
Junior Member
Join Date: Feb 2018
Posts: 1
Default Engine and transmission still rocks

2012 Nissan Versa Hatchback 1.8S w/104,000 miles

I had replaced all 4 motor mounts and the engine still rocks back and forth when shifting from Park, down to Drive and shifting from Drive, up to Park. Also, when the car is in drive with the e-brake on, the engine still tilts up. I've been doing research and most of the replies said to change the mounts or do all the mounts. Even when all mounts were changed, again, it still rocks. Is there other parts that could be causing this? The mounts that I put on are not OEM, but I believe even if I got OEM mounts, it would not make any difference because there's been people out there that had done it and said it still rocks. I'm thinking there might be other cause but can't figure it out.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 07:42 PM.

cars connected social network

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc. recognizes that "Infiniti", "Nissan", it's logos and various model names and numbers are registered trademarks of Nissan Motor Co. Ltd.. These terms are used for identification purposes only. is not affiliated in any way with Nissan Motor Co. Ltd. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 Madison Ross Media Group. All rights reserved. Content published on requires permission for reprint.
Need products for your Nissan? Check out your options at the links below: