nissan forums   nissan forums

Go Back   Nissan Forum > Nissan Forums (Nissan Trucks and SUVs) > Nissan Rogue Forum

Nissan Forum: 2009 Rogue engine noises
Reply
 
Thread Tools Display Modes
  #1  
Old 04-22-2019, 04:33 PM
Reset Reset is offline
Junior Member
 
Join Date: Apr 2019
Posts: 1
Default 2009 Rogue engine noises

Hi all, new member here. I have a 2009 Rogue with about 87K miles on it. I have noticed some noise coming from the engine bay, and I'm not familiar with them. There is a noise when first started and clears up after a minute, and a noise when the engine is shut off. I'm including a link to a YouTube video.

https://www.youtube.com/watch?v=1_dYO5cnNrw

Does anyone knows what might be causing these noises? Thanks!
Reply With Quote

Reply

Tags
engine noise

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 05:05 PM.


Advertisements
cars connected social network




Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
nissanforum.org recognizes that "Infiniti", "Nissan", it's logos and various model names and numbers are registered trademarks of Nissan Motor Co. Ltd.. These terms are used for identification purposes only. nissanforum.org is not affiliated in any way with Nissan Motor Co. Ltd. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2019 Madison Ross Media Group. All rights reserved. Content published on NissanForum.org requires permission for reprint. Interested in an affordable, reliable luxury SUV? Check out the Kia Telluride.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Nissan? Check out your options at the links below: