nissan forums   nissan forums

Go Back   Nissan Forum > Nissan Forums (Nissan Cars) > Nissan Altima Forum

Nissan Forum: 2006 altima 2.5
Reply
 
Thread Tools Display Modes
  #1  
Old 12-11-2015, 02:12 AM
34s2104 34s2104 is offline
Junior Member
 
Join Date: Dec 2015
Posts: 1
Default 2006 altima 2.5

hi guys, i'm new to the forum.

i bought a 06 altima 2.5

3rd cylinder was bad and i decided to replace the engine,the car was running almost perfect except the 3rd cylinder. the compression on that cylinder was 40 psi.

i bought the same engine from a junkyard.

i replaced it myself and it was a pia took almost 2 days to get the new one on place.

after all i couldnt start it

it cranks fine- engine sounds good when cranking but no start

first day after too many attempts ignition fuse was blown and i replaced it

second day (theres spark on all cylinders) after too many attempts i realised gas not coming to engine anymore.
i checked the fuse of fuel pump its ok, also replaced fuel pump relay with another same kind relay still pump doesnt work.

third day i took all the sensor off from the old engine (it was still running good with 3 cyl) and put them on the new engine no change !!!!!

fourth day i get in the car turn key to on position, i still can not hear pump but engine fan comes on directly, alarm indicator led stops blinking and stays on

i did not drive the car for long time and i dont know its behaviors but it doesnt sound normal to me, i messed something or it needs to be reprogrammed or something

notes :

when i was placing the new engine on it i made a few scratches on the flywheel i couldnt see any sensors on it but just an information

my alarm remote is not working (it wasnt working before i replaced the engine) i dont know if i need to lock and unlock the doors to set the alarm system off before starting first time.

i am pretty sure i never damaged any cables and the battery was not connected when i was replacing engine. i dont get any codes obd scanner.

Anyone has any advice for me ???
Reply With Quote

Reply

Tags
engine, engine swap, starting problems

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 10:51 AM.


Advertisements
cars connected social network




Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
nissanforum.org recognizes that "Infiniti", "Nissan", it's logos and various model names and numbers are registered trademarks of Nissan Motor Co. Ltd.. These terms are used for identification purposes only. nissanforum.org is not affiliated in any way with Nissan Motor Co. Ltd. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2019 Madison Ross Media Group. All rights reserved. Content published on NissanForum.org requires permission for reprint. Interested in an affordable, reliable luxury SUV? Check out the Kia Telluride.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Nissan? Check out your options at the links below: